BluePay Canada Processing Issue
Incident Report for BluePay
Resolved
The issue affecting the BluePay Canada transaction processing has been resolved. We apologize for any inconvenience this may have caused. Your business is very important to us, and we strive to provide you with exceptional and secure payment processing solutions.
Posted 3 months ago. Apr 13, 2019 - 08:30 CDT
Update
The issue affecting BluePay Canada transaction processing has been resolved. We apologize for any inconvenience this may have caused. Your business is very important to us, and we strive to provide you with exceptional and secure payment processing solutions.
Posted 3 months ago. Apr 13, 2019 - 08:28 CDT
Update
The issue affecting the BluePay Canada transaction processing has been resolved. We apologize for any inconvenience this may have caused. Your business is very important to us, and we strive to provide you with exceptional and secure payment processing solutions.
Posted 3 months ago. Apr 13, 2019 - 08:27 CDT
Investigating
We are aware of an incident that is currently affecting BluePay Canada merchants. We are working to resolve the issue as quickly as possible, and we apologize for any disruption this may cause.
Posted 3 months ago. Apr 13, 2019 - 08:05 CDT
This incident affected: Payment Gateway (Transaction Processing, Settlement).