BluePay 02/08/2024 2am CST First Data North Settlement Issue
Incident Report for BluePay
Resolved
The issue has been resolved. The 2/14/2024 settlements containing transactions from 2/7/2024 and 2/13/2024 settled and were funded. We appreciate your patience while we worked through this issue.
Posted Feb 15, 2024 - 16:35 CST
Monitoring
All outstanding transactions have now been settled. We will continue to monitor settlement to confirm the issue is resolved.
Posted Feb 14, 2024 - 14:38 CST
Identified
The issue preventing BluePay First Data North settlement has been identified. We plan to reattempt settlement of all unsettled First Data North transactions this afternoon.
Posted Feb 14, 2024 - 12:35 CST
Investigating
The settlement of the transactions from the 02/08/2024 2am CST settlements and new transactions that should have settled 02/14/2024 2am CST have failed to settle. We are working on a solution to get these transactions settled.
Posted Feb 14, 2024 - 10:32 CST
Update
The settlement of the transactions from the 02/08/2024 2am CST settlements have been delayed a day. They will settle as part of the 2/14/2024 2am CST settlement.
Posted Feb 13, 2024 - 09:31 CST
Monitoring
The failed settlements have been rolled back. The transactions from those settlements will settle as part of the next scheduled settlement.
Posted Feb 12, 2024 - 18:45 CST
Investigating
We are currently investigating an issue with the 02/08/2024 2am CST First Data North settlement. Settlements at other times or on other processing platforms were not affected by this issue.
Posted Feb 12, 2024 - 16:49 CST
This incident affected: Payment Gateway (Settlement).