Credit Card Funding Delay (September 21)

Incident Report for BluePay

Resolved

This incident has been resolved.
Posted Sep 22, 2026 - 13:44 CDT

Identified

Please be advised, some merchants may experience a funding delay for KeyBank and Citizens Bank. Impacted merchants can expect to see funds deposited after a 24-hour delay. Please note, this issue has no impact on the ability to process transactions.
Posted Sep 22, 2026 - 08:25 CDT
This incident affected: Payment Gateway (Settlement).