BluePay BlueChex ACH 03/11/2020 Deposits Delayed
Incident Report for BluePay
Resolved
03/11/2020 deposits should now be available in destination bank accounts. We apologize for any inconvenience this may have caused. Your business is very important to us, and we strive to provide you with exceptional and secure payment processing solutions.
Posted Mar 13, 2020 - 07:58 CDT
Monitoring
BlueChex ACH deposits that were scheduled for 03/11/2020 are delayed until 03/13/2020 due to a communications error. ACH Direct and credit card processing are not affected by this issue. We apologize for any inconvenience this may cause.
Posted Mar 12, 2020 - 11:45 CDT
This incident affected: Payment Gateway (Transaction Processing).