BluePay Gateway Issue

Incident Report for BluePay

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 18:43 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 10, 2025 - 13:08 CDT

Investigating

An issue is currently affecting the BluePay gateway and Fiserv ACH. We are currently investigating.
Posted Jul 10, 2025 - 12:34 CDT
This incident affected: Payment Gateway (Transaction Processing, APIs, Web Interface, Settlement, 3rd Party Services, Transaction Notification) and Web Interface, APIs.