First Data North and ACH Settlement Issue
Incident Report for BluePay
Resolved
The settlement issue that affected the BluePay Gateway has been resolved. We apologize for any inconvenience this may have caused.
Posted Feb 21, 2024 - 15:22 CST
Monitoring
All outstanding Bank of America direct to bank ACH transactions have been settled.

We will be monitoring the settlements closely to verify that the issue completely resolved.
Posted Feb 20, 2024 - 12:30 CST
Update
All outstanding First Data North credit card transactions have been settled. Transactions that should have funded today, 2/20/2024, will be funded 2/21/2024.

All ACH transactions have been settled except for Bank of America Direct to Bank. We are continuing to work on the final bank's settlement.
Posted Feb 20, 2024 - 10:30 CST
Identified
The cause of the issue has been identified and a solution is being implemented.
Posted Feb 20, 2024 - 09:12 CST
Investigating
We are currently investigating a settlement issue that is affecting First Data North and some ACH settlements. There is no impact to transaction processing.
Posted Feb 20, 2024 - 08:29 CST
This incident affected: Payment Gateway (Settlement).