BluePay Recurring Billing Issue
Incident Report for BluePay
Resolved
All delayed recurring transactions have been processed. The recurring billing system is now working normally.
Posted May 08, 2023 - 12:24 CDT
Monitoring
Recurring billings scheduled 5/7/2023 or later have been delayed. The issue has been corrected and the recurring billing system is currently processing the past due transactions.
Posted May 08, 2023 - 10:36 CDT
This incident affected: Payment Gateway (Transaction Processing).