Bluepay Incident - Failed transactions between 6:40 AM ET and 7:20 AM ET
Incident Report for BluePay
Resolved
This incident has been resolved.
Posted Sep 27, 2024 - 09:09 CDT
Investigating
Intermittent slowness due a communication issue may have caused some Bluepay transactions to fail between 6:40 AM ET and 7:20 AM ET.
Transactions that failed during that time will need to be reprocessed.
Posted Sep 26, 2024 - 09:39 CDT
This incident affected: Payment Gateway (Transaction Processing).