BluePay processing issue for Canadian Payroc merchants

Incident Report for BluePay

Resolved

Payroc transaction processing continues work normally. The issue has been resolved.
Posted Sep 21, 2023 - 19:21 CDT

Monitoring

Payroc has resolved their issue. Transactions are now processing. We are continuing to monitor the transactions.
Posted Sep 21, 2023 - 15:57 CDT

Investigating

We are currently investigating the issue.
Posted Sep 21, 2023 - 14:06 CDT
This incident affected: Payment Gateway (Transaction Processing, APIs, Web Interface, Settlement) and Web Interface, APIs.