BlueChex Reserve ACH Transfers Delayed
Incident Report for BluePay
Resolved
Processing is complete for the delayed transactions. Withdrawals and deposits will show on accounts on Friday 06/07/2019.
Posted 2 months ago. Jun 06, 2019 - 11:41 CDT
Identified
ACH Transfers from payers settled 06/05/2019 and payouts due for 06/06/2019 deposit have been delayed one day. We apologize for any inconvenience this causes. BlueChex Direct ACH processing is not affected.
Posted 2 months ago. Jun 06, 2019 - 11:04 CDT
This incident affected: Payment Gateway (Settlement).